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Chapter 1 Get Started

Foxit Reader Overview

System Requirements

Install Foxit Reader

Uninstall Foxit Reader

Update Foxit Reader
Workspace

Foxit Reader Overview

Foxit Reader is an easy-to-use PDF reader that lets you read, annotate, and protect PDF

documents on your Linux system.

Key Features

High quality PDF rendering for viewing

Add comments and annotations in PDF files with a full set of feature rich annotation tools
Decrypt and encrypt Microsoft Active Directory® or Azure Rights Management Services
protected PDF files

Search text to find specific information

Easily navigate PDF files by page, bookmark, or thumbnail

Flexibly view PDF files in Single Page, Continuous Page, or Rotate View mode

Participate in cloud-based shared reviews

Work with ConnectedPDF

System Requirements

Foxit Reader runs successfully in the following systems:

Ubuntu Desktop 14.04

Ubuntu Desktop 14.10

Ubuntu Desktop 15.04

Ubuntu Desktop 16.04

Red Hat Enterprise Linux Server 7.0
SUSE 12 Linux Enterprise Server
OpenSUSE 13.2

For users utilizing the Active Directory Rights Management Service, the following systems will run

successfully:

Ubuntu Desktop 14.04
Ubuntu Desktop 14.10
Ubuntu Desktop 15.04



° Red Hat Enterprise Linux Server 7.0
e  OpenSUSE 13.2

Install Foxit Reader

Choose one of the following methods to install Foxit Reader:

e Double click the executable file you downloaded, and then follow the step-by-step
instructions in the Installation Wizard to install Foxit Reader on your computer.

e Use the following Terminal command line:

a. Change to the directory containing the downloaded file (used /tmp as the example):
#cd /tmp

b. Uncompress the executable file

# gzip -d 'FoxitReader_version_Setup.run.tar.gz'

c. Untar the .tar file

# tar xvf 'FoxitReader_version_Setup.run.tar'

d. Run the installer:

# ./'FoxitReader_version_Setup.run'

e. Follow the steps on the screen to complete the installation

Uninstall Foxit Reader

Double click the Uninstaller file in the Foxit Reader installation directory.

Update Foxit Reader

You can choose one of the following options to update Foxit Reader:

e  Goto Help > Check for Updates Now to check and update Foxit Reader to the latest version.
e Go to Edit > Preferences > Updater, and check the Automatically check for updates
(Recommended) option to update Foxit Reader automatically whenever a newer version is

available.
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Foxit is a leading software provider of fast, affordable, and secure PDF solutions. Businesses
and consumers increase productivity by using Foxit's cost effective solutions to securely work
with PDF documents and forms. Software developers reduce costs and improve time to
market with Foxit's Software Development Kits (SDKs) to incorporate robust PDF technology
into their i . This shares the same underlying technology that
powers Googla's open-source PDFium project. Winner of numerous awards, Foxit boasts
over 275 million users and has sold to over 100,000 customers located in over 200 countries.

Since Foxit products are 1SO 32000-1/PDF 1.7 standard compliant, they are compatible with
other PDF products like those from Adobe®.

Foxit provides the following product offerings to our customers:

+ Foxit Reader - Small, fast, and feature rich PDF viewer which allows you to open, view,
and print any PDF file. Unlike other free PDF readers, Foxit Reader also includes easy
10 use collaboration features like the ability 10 add annotations, fill out ferms, and share
content with social networks. It is designed to meet the PDF viewing needs of enterprise
and government organizations, making it easy to deploy and manage in large enterprise
environments. Foxit Reader can also be customized to specific product features and
branding.

« Foxit MobilePDF - Allows users to work on PDF documents while on the go with any

Andrnid or iPad device Ruilt an the same technolnoy ae Eovit Rearder hMohileBPOE

Generally, Foxit Reader’s interface includes five parts: Menu bar, Common

Navigation Panel, Document Pane, and Tab bar.

Tools toolbar,

A. Menu bar: Includes the major menus of Foxit Reader. You can find all the tools and commands

to render PDF pages, page objects, annotations, and forms here.

B. Common Tools toolbar: Contains commonly used tools in Foxit Reader.

Navigation panel icon: Show or hide the navigation panel.

Print: Print the currently opened PDF file.

Save: Save the changes you made to the PDF file.

LRI

Zoom tools: Zoom in or out of the PDF file.

Page navigation tools: Jump to the specific page of the currently opened PDF file.

View: Change the page display mode or page orientation.

Comments: Add comments to the PDF file.

Protect: Decrypt and encrypt Microsoft Active Directory® or Azure Rights Management

Services protected PDF files with the optional Foxit RMS plug-in.

Highlight: Highlight the selected text.

Typewriter: Add text to the PDF file.

Find: Search the document to find specific text.

C. Navigation Panel: Display Bookmark panel and Page panel to help you navigate in the PDF file
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easily.
D. Document Pane: Display the currently opened PDF file.
E. Tab bar: Display multiple PDF files in tabs. You can go back and forth between PDF files by

using the Document tab®® . You can also click **to check recently opened PDF files.



Chapter 2 View PDF Files

Open a PDF File
Adjust PDF Views

Search and Find Text
Navigate PDF Files

Open a PDF File

Please choose one of the following to open a PDF file with Foxit Reader:

Choose File > Open > select the PDF file in the Open dialog box > click Open.

Launch Foxit Reader, then drag and drop the PDF file in the Foxit Reader workspace.

Right click the PDF file, and choose Open With Foxit Reader.

If you have set Foxit Reader as the default PDF reader, you can double click the PDF file
directly to open it with Foxit Reader.

Click 7 on the lower left corner of the main interface > click > select the PDF file >

click Open.

Adjust PDF Views

Change the Page Display Mode

. View |
Click © View in the Common Tools toolbar;

Choose one of the following options:

5 Q| 107% v @& | 4 |61/201 P
2 &5 B &8 TG
1 2 3

Single Page: Display one page at a time.

S Continuous: Display the pages in a continuous vertical column.
= Facing: Display two pages side by side at a time.

2 Continuous Facing: Display facing pages side by side in a continuous vertical column.

Tip: Alternatively, you can choose View > Page Display, and then select the desired mode from

the drop-down menu.



Resize the Page View

Use the Zoom tools in the Common Tools toolbar to adjust the zoom level of the page.
1 ) z

Q| 100% |v) &

4) Actual Size 50%

s) Fit Page 3 66.6%
&) Fit width 75%

7 Fit Visible 100%
1

Zoom QOut: Zoom out of the page.

o

Zoom In: Zoom in the page for a clearer view.

1

Zoom To: Resize the page to a specific zoom level £ or make the page fit the window )

Actual Size: Display the page in its actual size.

h (B

Fit Page: Resize the page to fit entirely in the document pane.

Ly

Fit Width: Resize the page to fit the width of the window. Part of the page may be out of
view.
Fit Visible: Resize the page to make the text and images fit the visible width of the window,

removing the margins.

Tip: Alternatively, you can choose View > Zoom, and then choose one option from the
drop-down menu to adjust the zoom level.

Rotate the Page View

Do one of the following to rotate the view of the document pages:

e  Goto View > Rotate View > Rotate Right or Rotate Left.

-

o  C(Click O View in the Common Tools toolbar > choose Rotate Leftm':] or Rotate Right o

o Rightclick the document, and choose Rotate Right or Rotate Left.

Note: Foxit Reader allows you to rotate pages in 90-degree increments. Pages are rotated for
viewing purposes only, and no changes to page orientation will be saved to the PDF file.



Search and Find Text

Use the Find tools in the Common Tools toolbar to search and find text.

Q- foxit 1 )

— Case-Sensitive
Whale Words Only
e Input textin the search box.

. CIick'fl ", and check the following option(s) if needed:

A. Case-Sensitive: Make the search case sensitive.
B. Whole Word Only: Limit the search to match only whole words.
e Press Enter to search the text in the currently opened PDF file.

e Click Yort to jump to the previous or next search result.

Navigate PDF Files

Jump to a Specific Page

Use the page navigation tools in the Common Tools toolbar to jump to a specific page easily.

4 65/201

2 i =

£ Page indicator: Shows the current page and the total number of pages of the opened PDF file.
You can input the page number and press Enter to jump to the page specified.
£ Previous Page: Jump to the previous page.

2 Next Page: Jump to the next page.

Tip: Alternatively, you can go to View > Go to, and then choose one option from the drop-down
menu to jump to a specific page. From the drop-down menu, you can also choose to jump to the
first page or the last page of the PDF file.

Jump to a Specific Chapter by Bookmark

. CIick in the Common Tools toolbar to open the Navigation panel if it is hidden;



e (Click the Bookmark button on the Navigation pane to open the Bookmarks pane;
e Click the bookmark to jump to the specific chapter.

il 2) (3
Contents

S Chapter 1 - Introducti...
+ Chapter 2 - Getting St...
+ Chapter 3 - Viewing P...
T Chapter 4 - Working ...

+ Chapter 5 - Comments
+ Chapter 6 —Form

Jump to a Page by Thumbnail

Additional actions in the Bookmarks pane:

%' Add a bookmark: Save the current view as a
bookmark.
% Delete the bookmark: Delete the selected
bookmark.
2 Expand/Collapse: Expand or collapse all

bookmarks.

e  (Click?'in the Common Tools toolbar to open the Navigation page if it is hidden;

e  C(lick the Page button on the Navigation pane to open the Page pane;

e  (Click the thumbnail to jump to the specific page.

Additional actions in the Pages pane:

£ Enlarge Page Thumbnail: Enlarge the size of the
page thumbnail.

Reduce Page Thumbnail: Reduce the size of the
page thumbnail.

Rectangle box: The red rectangle box shows the
current visible area of the page. You can drag and
move the red rectangle box to move to another
location on the current page. Besides, you can
drag the resize handle on the bottom right corner
of the red box to resize the visible area of the

current page.
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Open a File Attachment

Open a file attachment embedded in a PDF file

o click™/in the Common Tools toolbar to open the Navigation pane if it is hidden;

e  Click the Attachment button

on the Navigation pane to open the Attachments pane;

e Double click the file that you want to open with Foxit Reader.

e Inthe Open File Attachment dialog box, choose the option as desired, and click OK.

Attachments

w 3
Add Attachmenks..<2
Add and Pin Attachment..<2

— e g e =

SharePoint Configuration.pdf

Web Service Configuration.pdf

Open a file attachment pinned in the PDF file

Additional actions in the Attachment pane:

= Add Attachments: Add a file attachment

to the PDF file.
%' Add and Pin Attachment: Add a file
attachment, which will also display a pin icon,
to the PDF file.
Settings: Manage file attachment

security settings in the Preferences.

The file attachment pinned in the PDF file is usually displayed with a pin icon. You can double

click the pin icon to open it with Foxit Reader.



Chapter 3 Comment

e  Overview

e Add Comments in the PDF File
Add a Text Markup

Add a Note Comment

Add a Drawing Markup

Draw a Free-form Shape
Add a Text Comment

e

° Manage Comments

<> Change the Appearances of Comments

<> Move the Comments

<> Delete the Comments

e Join Cloud-based Shared Review

Overview

Foxit Reader provides a full set of feature rich tools to help you comment on PDF files easily.
Comment tools include the Text Markup tools, Typewriter, Note tool, and Drawing tools.

() Q| 8g7% v & 1/2 | ¥ © View A Protect |v LTI |~
| 5
Z U U T T T T Bv Ev | B8v B Sy e B
i 2 x5 4
Text Markup Tools: Add text markups to the PDF file.
pri

Typewriter Tools: Add a line of text to the PDF file.

Pin Tools: Add a note comment or file attachment to the PDF file.

A

Drawing Markup Tools: Add drawing markups to the PDF file.

0

Highlight Tool: Highlight the selected text in the PDF file.

Add Comments in the PDF File

Add a Text Markup

—
Click &' Comments in the Common Tools toolbar;

e Choose one of the following comment tools:

H @ 6 @ 6 @ 10



Highlight: Highlight the selected text.

1Y

Squiggly: Draw a squiggly line under the selected text.

W

Underline: Mark the selected text with an underline.
Strikeout: Mark the selected text with a strikeout.

Replace: Draw a line to cross out the selected text and provide a substitute for it.

LRI R

Insert: Insert text in the place desired.

To highlight, squiggly mark, underline or strike out the text, do the following:

>  Select the text;

> If needed, double click the selected text to open the pop-up window, and input the
text.

To replace the text, do the following:

»  Select the text;

> Input the text in the pop-up window to provide a substitute for it.

To insert text, do the following:

»  Click the place where you want to insert the text;

> Input the text in the pop-up window.

Add a Note Comment

—
Click &' Comments in the Common Tools toolbar;

| . Note 7/24/15 14:15:21
Choose a note style from the drop-down list ™ ~ ; Foxit Options
Click the place where you want to add the note Foxit Software
comment.

Input the comment in the pop-up window.

other POF products like those from Adobe®.

Add a Drawing Markup

Add a Rectangle, Line, Arrow, or Oval

=
Click &' Comments in the Common Tools toolbar;

Click < , and choose one of the following drawing markup tools:

11
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o~ » 0O
1 (2 2 4
& Rectangle: Draw a rectangle in the PDF file.
& Line: Draw a straight line in the PDF file.
Arrow: Place an arrow in the PDF file.
4

Oval: Draw an oval in the PDF file.

e Drag the cursor across the area in the document
where you want to add the markup to.

Draw a Free-form Shape

=
Click &' Comments in the Common Tools toolbar;

e  Choose the Pencil tool 4 ;

. Draw on the PDF file as desired;

e If you need to erase the pencil markup, click the

Eraser tool o , and drag to select the pencil markup

you want to erase.

Highlight an Area

& Comments

° Click in the Common Tools

toolbar;

e Choose the Area Highlight tool ;

e  (Click and drag the mouse over the area in the
document you want highlighted.

Add a Text Comment

e Click & Comments

° Choose one of the tool as desired:

Foxilis a leading software provider of fas

powers Google's open-source PDFium pr

Foxit Is a leading software provider of {ast, afforda
and consurmers increasefriductivity by using Fox

with PDF documents a

Since Foxit products are 150 32000-1/PDF 1.7 st
other POF products like those from Adobe®.

Foxit is a leading software provider of fast, afforda
and consumers increase productivity by using Fox
with PDF documents and forms. Software develop
market with Foxit's Software Development Kits (SI
into their application workflows. This technology st
powers Google's open-source PDFium project. Wi
over 275 million users and has sold to over 100,0C

in the Common Tools toolbar;

12
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1 2 >

['m adding text with Textbox tool |

£ Typewriter: Add a text comment without any text box.
2 . I'm adding a line of text with Typewriter tool
Textbox: Add a text comment in a text box.
E Callout: Add a text comment in a callout text box.
Foxit is a leading softwane provider of fast, &
e Click on the document where you want to add the and consumejj'm, adding text by usir
comment, and type the text as desired; with PDF docjwith Callout tool  ftware di

e  Select the text, and click " to set the font, font

color, font size, font style, and text alignment.

1 Helvetica
% Font: Set the font of the text. | v

Z Color: Set the color of the text. :2 . '. . . "
B I u

2 Font size: Set the font size of the text. 5>(10 v
* Font style: Set the font style of the text. = = &
=

Alignment: Align the text to the left, right or center.

Manage Comments

Change the Appearances of Comments

e Do one of the following to open the Properties dialog box:
A) Right click the comment, and choose Properties from the context menu.
B) Click Options in the comment pop-up window, and choose Properties.

e  Change the thickness, color, opacity, and other settings in the Properties dialog box.
Tip: In the Properties dialog box, you can: 1) check Locked option to lock the current settings and

prevent others from changing the properties; 2) check Set Current Properties as Default option

to set the current properties as the default.

Move the Comments

e  Select Tools > Default Mode;
o  (Click the comment that you want to move, and then drag and move it to the desired place.

Note: You cannot move the text markups.

13



Delete the Comments

Please do one of the following to delete a comment:

e  Right click the comment, and choose Delete from the context menu;
e  Select the comment, and press the Delete key;
e  Select Options from the comment pop-up window, and choose Delete.

Reply to Comments

e  Open the pop-up note of the comment that you want to reply to with one of the following
methods:
>  Double click the comment that you want to reply to;
> Right click the comment that you want to reply to, and select Open Popup Note from
the context menu.
e Inthe pop-up note, click Options, and select Reply from the context menu;

e  Input the text as desired.

Join Cloud-based Shared Review

Foxit Reader allows users to participate in the cloud-based shared review initiated by Foxit
PhantomPDF Business. During the shared review, review participants can read, reply, and share

comments with the Foxit Cloud service.

% AboutFoxit_review.pdf * - Foxit Reader
Fi Edit Connect Share Hel

ile View Tools Comments Protect elp
=B E Q) 125% v\ ® 12 v @ view | B Comments | Z Connect |~ |Z£ T v Q- v
Start Datasheet_Reader... [Z: AboutFoxit_con... | AboutFoxit_review....X
=) Please add your comments and click Publish Comments so that ) = ; &l
V& other reviewers can see them.Deadline:NO Deadline D i L T e U D

i 2 >

Foxit is a leading software provider of fast, affordable, and secure PDF solutions. Businesses
and consumers increase productivity by using Foxit's cost effective solutions to securely work
| with PDF documents and forms. Software developers reduce costs and improve time to
market with Foxit's Software Development Kits (SDKs) to incorporate robust PDF technology
| into their application workflows. This technology shares the same underlying technology that
powers Google’s open-source PDFium project. Winner of numerous awards, Foxit boasts
over 427 million users and has sold to over 100,000 customers located in over 200 countries.

Since Foxit products are ISO 32000-1/PDF 1.7 standard compliant, they are compatible with
other PDF products like those from Adobe®.

_ Check For New Comments: Check for new comments from other review participants.

14



Z Publish Comments: Publish and upload your comments to a network server.

Review Option:

< Track Reviews: View the detailed information of the shared review you have joined,
including the initiator, reviewer, status, and more.

<~ Save as Archive Copy: Save the PDF file with comments as a copy that is no longer
connected to the shared review.

<> Work Offline: Disconnect from the network server. In offline mode, you can only add
comments, but cannot publish or check for new comments until switching to online
mode.

To join the cloud-based shared review, please follow the steps below:

e  Download the PDF file to be reviewed from the Foxit Cloud service, and open it with Foxit
Reader.

e If you open the PDF file to be reviewed with Foxit Reader for the first time, you will need to
complete your identity information first (as shown below).

@ Identity Setup

Please enter your identity information so that other review participants will
recongnize your coments. You can always change your identity information in the
Preferences - Identity tab.

Name: ll

Email Address:

Cancel oK |

e Add comments as desired in the PDF file.
e Upon completion, click Publish Comments in the message bar to share your comments with
other reviewers.
o  If necessary, save the PDF file with one of the following methods:
» Choose File > Save As to save the shared PDF file as a copy in your local disk. You can
reopen this copy to continue reviewing or send the document to other reviewers for
further shared review.

a
»  Click the Review Option buttonlz in the message bar, and choose Save as Archive

Copy to save the PDF file with review comments as a copy that is no longer connected
to the shared review.

To rejoin the cloud-based shared review, please follow the steps below:

e  Reopen the PDF file to be reviewed with one of the following methods:

15



» Open the PDF copy with Foxit Reader directly if you have saved it in your local disk
before.

»  Select Share > Tracker, right click the PDF file that you want to review, and then select
Open from the context menu.

Follow the same steps specified above to continue the shared review.

16



Chapter 4 RMS Encryption and Decryption

° Overview

° Prerequisites
° RMS Encryption
° Foxit Configuration Tool (Used in Windows RMS Server)

° RMS Decryption
° Change RMS Account

Overview

Foxit Reader integrates RMS plugin in the software to extend the access control of Microsoft
Windows Server® AD RMS on client systems. You will be offered a 30-day trial for RMS functions.
To continue to use RMS functions after the evaluation period, you can contact Foxit to purchase
a RMS license for the Foxit RMS plug-in.

Prerequisites

If you are using the Microsoft Azure Rights Management (Azure RMS) environment, you can log

in to the RMS server directly within Foxit Reader.

If you are using the Microsoft Active Directory Rights Management Services (AD RMS)

environment, you need to do the following deployment steps.
Step 1- Deploy Active Directory Rights Management Services

In order to use Microsoft Rights Management Services in your client system, you need to follow
Microsoft’s instructions to deploy the Active Directory Rights Management Services (AD RMS)
mobile device extension first. For detailed deployment steps, please refer to “Active Directory
Rights Management Services Mobile Device Extension”.

When deploying Active Directory Rights Management Service mobile device extension, you need
to run the following Windows PowerShell commands in order to authorize Foxit Reader for your

devices.

Add-AdfsClient -Name "Foxit Reader for Linux" -Clientld "f3295alc-bcfe-4430-80bf-1c0a5636

e8e8" -RedirectUri @("com.foxitsoftware.com.reader-for-linux://authorize")
Step 2- Install Certificate in the Client System
Get the certificate from your system administrator and install it in your client system by running

the following Terminal command:
17


https://technet.microsoft.com/en-us/library/a69ead9d-7dd3-4b38-9830-4728e9757341
https://technet.microsoft.com/en-us/library/a69ead9d-7dd3-4b38-9830-4728e9757341

sudo cp server.crt /etc/ssl/certs
(Note: In the command, the “server” is the name of the certificate.)

RMS Encryption

™
Click = Protect in the Common Tools toolbar;

e If you are using the RMS functions for the first time, choose Restrict Access > Connect to
Digital Right Management Servers and Get Templates to log in to the RMS server first.

e If you have logged in to the RMS server before, choose Restricted Access.

e  Select a template to encrypt the PDF file.

e If you don’t want to use the template, click Restricted Access option to specify the
permissions. Please refer to “Specify the Permissions to PDF Files” for more details.

Tip: Foxit Reader allows you to encrypt PDF files with the official rights policy templates as well as
custom templates. Official rights policy templates are based on the RMS server. Custom
templates are customized by users. For instructions on how to customize a template, please refer
to “Create Custom Templates”.

Specify the Permissions to PDF Files

e  Go to Protect > Restrict Access;

e Choose the Restricted Access option;

e In the pop-up Permission window, check Restrict permission to this document, and do the
following:

(==

1. Enter the email addresses of users in the respective boxes. You can also click =*' to

authorize all users with the permissions.
2. Click More Options to set additional permissions.
2.1. In the User List, click Add or Remove to add or remove an authorized user.
2.2. Check the additional permissions in the “Additional permissions for users”. You can click
Extended policy to control the following document usages:
»  Only allow access by this IP range: specify an IP range that is allowed to access a
document.
»  Only allow access to these pages: specify the page number(s) that a user is allow to
access.
» Number of accesses: specify the number of times that a user is allowed to access a
document.
» Number of prints: specify the number of times that a user is allowed to print a
document.

Note: To specify the “Number of accesses” and “Number of prints” items in an
on-premise environment, click the attached Web Service Configuration lto configure
18



Web Service Configuration

To use the features of dynamic revocation, number of accesses and number of prints (additional
access rights control), you should configure the web service and SQL first. Please follow the steps
as below:

1. Configure the Web Service on your on-premise RMS server.

a) Logon RMS server as Administrator.

b) Download the Web Service zip from:
For X86:
http://cdn01.foxitsoftware.com/pub/foxit/rms/configtool/8.x/WebService 32.zip
For X64:
http://cdn01.foxitsoftware.com/pub/foxit/rms/configtool/8.x/WebService 64.zip

¢) Unzip the Web Service zip and get the fxrmsext from it.

d) Copy the fxrmsext to C:\inetpub\wwwroot\_wmcs.

[ &M= _wmcs
“ Home Share View
®© - 1| » Computer » Local Disk(C:) » inetpub b wwwroot » _wmes b v c‘,| [ search_
a

' Favorites Mame Date modified Type Size

B Desktop admin 8/2 9:10 AM File folder
& Downloads certification Al File folder
= Recent places decommission File folder

frrmsext File folder

= Libraries groupexpansion File folder
5 Documents licensing File folder
& Music 3 web.config XML Configuratio... 1 KB
&) Pictures

e) Run “Internet Information Services” (IIS).
f) Right-click “_wmcs”, and then choose “Add Application...”.



http://cdn01.foxitsoftware.com/pub/foxit/rms/configtool/8.x/WebService_32.zip

http://cdn01.foxitsoftware.com/pub/foxit/rms/configtool/8.x/WebService_64.zip



& » DRS » Sites » DefaultWebSite » _wmcs »

File View Help

Q,_- =TEAY H? /_wmcs Home
g ?ﬂ Start Page .
i Filter: - W Go - Show All | G g
493 DRS (FRMS\administrator) fer o - Show All | Group by: Area
----- [} Application Pools ASP.NET
a-[8] Sites . @ - r'\ 15
. ic 2 @ F K
{E _wmcs MNET MET] .MET Error MET MET Profile  .MET Reh
b acﬂ Explore ilgtion Pages Globalization
4 "? b Edit Permissions...
I+ é“ d
Dn‘? gr|_n§ Add Application...
b lig ;7 Add Virtual Directory...
Dﬂ CertE Manage Application »
bP CentS|[E  Refresh @ o
K Remove entic... Compression  Default Directory  Error Pag
2 Switch to Content View Document  Browsing
=
- =
Request  S5L Settings
Filterinn

g) Input the following information into the Add Application dialog box.
® Alias: fxrmsext
®  Physical path: C:\inetpub\wwwroot\_wmcs\fxrmsext

Site name:  Default Web Site
Path: f_wmcs

Alias: Application pool:
(frrmsext | |_DRMSAppPOoI

Example: sales

Physical path:
| Chinetpub\wwwroot\_wmcs\frrmsext

Pass-through authentication

‘ Connect as... ‘ | Test Settings...

["] Enable Preload

h) To avoid repeated authentication, we should disable the Windows Authentication and
enable the Anonymous Authentication. Click “fxmsext” in Connections Pane, and then
double-click “Authentication”.

NOTE: For data communication security, PDFs will be encrypted with AES algorithm by
default.





2. Configure the SQL.

a)
b)

@ » DRS » Sites » Default WebSite » _wmes » furmsext »

File  View Help
@-H|x|8
----- E Start Page

495 DRS (FRMS\administrator)
-[Z} Application Pools
‘@ Sites

€ Default Web Site
) @ _wmcs
D@ admin
|‘> @ certification
D@ decommission
b@ groupexpansion

Cll
[:> | CertEnroll
I+ @ CertSrv

Enable the “Anonymous Authentication” and disable the “Windows Authentication”.

/_wmcs/fxrmsext Home

Filter: = W Go -5l ShowAll | Group by: Area ~ [~
ASP.NET
nY - o
5 B ® @
s S ¢ K © 2
NET NET .MET Error MET .MET Profile  .MET Roles  .NET Tr
Authorizat... Compilation Pages Globalization Level
=]
SMTP E-mail
115
3 o = (4]
= @ =) a4
ASp brpression  Default Directory  Error Pages Failet
Document  Browsing Request”
%‘ & | Configure authentication settings for sites and applications |
Request 550 Settings
Filterinn

[ » DRS » Sites » Default WebSite » _wmcs » furmsext »

File  View Help
@ -z
o ?ﬂ Start Page

195 DRS (FRMS\administrator)
@ Application Pools
4.[8) Sites

4 Default Web Site
A@ _wmcs
D@ admin
D@ certification
ST " —

Authentication

Group by: Mo Grouping =

MName - Status Response Type
Ancnymous Authentication Enabled

ASP.MET Impersonation Disabled

Forms Authentication Disabled HTTP 302 Login/Redirect
Windows Authentication Disabled HTTP 401 Challenge

Navigate to C:\inetpub\wwwroot\_wmcs\fxrmsext.
Right-click “Web.config” file -> “Open with” -> “Notepad”.





furmsext

Share View
, v Computer » Local Disk (C:) » inetpub » wwwroot » _wmcs » furmsext Y] G| E
MName Date modified Type Size
J bin /2014 7:34 AM File folder
ds #| fermsextservice.asmx 014 10:18 PM ASP.NET Web Ser... TKB
aces j Web.config S COMFIG File 2KB
Open
Edit
Tts Open with b | e Microsoft Visual Studio 2010
Restore previous versions | j Motepad
Send to 3 Choose default program...
Cut
Copy

Create shortcut
Delete

Rename

Properties

¢) If you want to log on to the SQL Server through Windows Authentication, you just need
to alter the SQL Server information by inputting the IP address or computer name and
then saving the change.

<appSettings>
<add key="MyDB"

value="Servers5QL2005; DataBase=RMSExtService;

Integrated Security=SSPI; Persist Security Info=False" >
</add>

NOTE: If the computer name include =), please ensure you are using SQL 2012 version or
higher.
d) If you want to log on to the SQL Server through SQL Server Authentication, please
follow the steps:
i. Copy “Server=SQL2005; DataBase=RMSExtService; User ID=myUsername;
Password=myPassword”.
ii. Paste and replace “Server=SQL2005; DataBase=RMSExtService; Integrated
Security=SSPI; Persist Security Info=False”.

fie Edt_Fomat View Help
<?xml version="1.0"?>
<configuration>
<lan
|"SeNer\=SQL2205; DataBase=RMSExtService; User ID=myUsername; Password=myPassword"
-

<appSettings> \
<add key="MyDB"
values"Server=50L208085; DataBase=RMSExtService; Integrated Security=SSPI; Persist Security Infn=False"|>
</add>

</appSettings>

iii. Alter the SQL Server information. You can input the IP address or the computer

name.
iv. Alther the “User ID” and “Password”.
V. Save changes.

e) Create the data base and tables.
i Log on to the SQL Server as Administrator.





Get the .sql file from the Web Service zip you downloaded before.

. . g . “ ”
iii. Double-click this file to create the database and tables, and then click “Execute”.
In CreateDatabaseRMSExtService.sql - DRS.RMSExtService (sa (53)) - Microsoft SQL Server Management Studio (Administrator) == -
File Edit View Query Project Debug Tools Window Help
PG - 5 b @ | ) NewQuery [y 55 0 | 4 G2 3|9 - o - G- @ 2
i %) U | [RMSEdService -l ¥ Execute | b Debug =
Object Explorer s CreateDatabaseRMSE.. xtService (sa (33)) X _
Connect> 3 &) m 7 (2] ' Jlif object_id( RMSExtService') IS NULL +
%1 | ) AppMng Service DB 12225206c2d040b0e3de250a68¢12ed |~ EEEATE DATABASE RiSExtService -
[+ LJ Bdc_Service_DB_50bbb629ede74caeda729501bbdc9el3
# |1 DRMS_Config_drs_frms_com_443 CREATE TABLE [RM
¥ L_I DRMS_DirectoryServices_drs_frms_com_443 GO o =
# | DRMS_Logging_drs_frms_com_443
# [ Managed Metadata Service_b112d53219884fc698b639dasted] _ SIIF not exists(select * from [RMSExtService].[dbo].[ConfigurationInfo])
# [J PerformancePoint Service Application_087793ecSc3f4c6c8988 = INSERT INTO [RMSExtService].[dbo].[ConfigurationInfe]([RevocationInterval
@ [ ReportServer Go
# 1 ReportServerTempDB ICREATE TABLE [RMSExtService].[dbo].[DocInfo]([ContentID] [varchar](5@) O
= [ RMSExtService: [TemplateName] [varchar](5@) NOT NULL,
# [ Database Diagrams [Creator] [varchar](5@
# [ Tables [FileName] [nvarchar](58) NOT HULL,
= 3 Views [CreateDate] [datetime] NOT NULL,
% [ Synonyms [PrintTimes] [int] NOT NULL,
# [ Programmability [OpenTimes] [int] NOT NULL,
= @ Service Broker [RevocationFlag] [bit] NOT NULL,
[IsRevecation] [bit] NOT NULL) ON [PRIMARY]
# [J Storage 50
# [ Security v
# [J RMSLog W% -« mn >
< - w T T S | 4] Connected. (1/1) DRS (1.0 RTM) | sa(53) = RMSExtService | 00:00:00 | 0 rows

f)  Grant RMS administrator the database operations rights.

i Open “Internet Information Services” (lIS).

ii. Click “Application Pools” in Connections Pane. Then you can get the account
information from Identity column.
€

Internet Information Services (I1S) Manager

@0 ‘Q v DRS » Application Pools

File View Help

qsl Application Pools

This page lets you view and manage the list of application pools on the server. Application pools are associated with worker processes, cor

applications.
ez Filter: - Go - gyShow All | Group by: N Grouping -
4 € Default Web Site Name = Status  NETFram.. Managed Pipel... |dentity Applications
4 '-? _wmes . ‘;‘\‘NETVA.S Started v Integrated ApplicationPoolldentity 0
b qadm_;_" . L5} NET v4.5 Classic Started w40 Classic ApplicationPoolldentity 0
b \F‘V ;E’tl Kat'_m {1} _DRMSAppPool1 Started w40 Classic LFR |
- decommission
»-E» groupespansion |} DefaultAppPool Started  vA.0 Integrated Applica 2
p (2 licensing
b2 famsext
I -] aspnet_client
iii. Open SQL Server management.
H H ", H ”n " H ”n
iv. Navigate to “Security” -> “Logins”.

V. Check if the RMS administrator account is listed.





s CreateDatabaseRMSExtService.sgl - DRS.RMSExtService
File Edit View Query Project Debug Tools Window Help

P10l S e @ | Sl NewQuery [y i | 6 A @[ <
Q#MHRMSE}CI:S&MC& '|| § Execute B Debug ¥ o |

Object Explorer

Connect= 3 & w 7 #] ﬁ

U WS5_Logging ~
= [ Security
= [ Logins
&, ##MS_PolicyEventProcessingLogin#
&, ##MS_PolicyTsqlExecutionLogin®#
A FRMS\Administrator
4 FRMS\rms_lo
% FRMS\rms_service I
% FRMS\sp_admin
A NT AUTHORITY\SYSTEM
£ NT Service\MSSQLSERVER
A NT SERVICE\ReportServer
A NT SERVICE\SCQLSERVERAGENT
A NT SERVICE\SQLWriter
& NT SERVICE\Winmgmt
& sa
[ Server Roles
[ Credentials
Ca Cryp.tographic Providers -
< m >

o

If yes, skip to Step vi.
If not, right-click “Logins”, then click “New Login”.
s CreateDatabaseRMSExtService.sql - DRS.RMSExtService

File Edit View Project Debug Tools Window Help
Pl D e | L NewQuery [y i i Ty | 4 0 ] 4

i 2 9 | [RmsExtservice | ¥ Bxecute P Debug ® |
Object Explorer -1 x
Connect~ 3 3 m F [&] .5
U WSS_Logging ~
= [ Security
i
&8, 22 Mew Login... in##
&, #2 Filter y
AR | —
A FR Start PowerShell
& FR Reports 4
AR

A NT Refresh
A NT Service\MSSQLSERVER
& NT SERVICE\ReportServer
A NT SERVICE\SQLSERVERAGENT
A NT SERVICE\SQL Writer
A NT SERVICE\Winmgmit
A sa
[ Server Roles
[ Credentials
Ca Cryp!tographic Providers o

< m ¥
S S S S S S Sl

Input the Login name, click OK.





Select a page

Scrpt ~ Hel
12 General g H IE .
1 Server Roles
12 User Mapping Login name: |FHMS\n‘ns_service | | Search... |
12 Securables ® )
% Status Windows authentication
() SQL Server authentication
Password: | |
Corfirm password: | |
[] Specify old password
Old password: | |
Enforce password policy
Enforce password expiration
User must change password at next login
) Mapped to cegtificate | v|
() Mapped to asymmetric key | v|
[] Map to Credential | v || Add
Server: Mapped Credentials Credential Provider
DRS
Connection:
53
37 View connection properties
Progress Remove
Ready Default database: |master b |
Default language: | <defautt> hd |
ok | [ Cancel |
£
vi. Grant RMS administrator as the database owner.
5 Seript v [ Hep
Users mapped to this login:
Securables Map Database User Default Schema |~
[ Status O Report Server
El SExtService | FRMS\ms_service dbo =
l_l —
O Search_Service_Appli... =
O Search_Service_Appli... L
O Search_Service_Appli...
O Search_Service_Appli...
[ Secure_Store_Service... ||
[T SharePairt AdminCon v
[[] Guest account enabled for: RMSExt Service
Database role membership for: RMSExt Service
Connection
[] db_accessadmin
Server: [] db_backupoperator
RMS [] db_datareader
Connection: (] db_datawriter
FRMS"administrator [] db_ddiadmin
&7 View connection properties Ll db'dewdatareer
. ] publi
public
Ready
ok | [ coneel |
TRV
g) Set up the firewall.
i In SQL Server Configuration Manager, expand SQL Native Client Configuration, and

click “Client Protocols” and right-click “TCP/IP Properties” to get the default port.






= Sql Server Configuration Manager

File Action View Help

> #n|E= 0
{8 SOL Server Configuration Manager (Local) || Name Order Enabled
B QL Server Services %~ Shared Memory 1 Enabled
4. 50L Server Network Configuration (32bit| [5=Tcp/p 2 Enabled |
3 g SQL Native Client 11.0 Configuration (32 [ 5= Named Pipes E) Enabled

b H. s0L Server Network Configuration

Protocol
Enabled Yes
Keep Alive 30000
Keep Alive Interval 1000
Default Port
Default port on which connection will be made
< o HE ok [ concel [[ ety [[ Hep |

Run “Windows Firewall” and click “Advanced settings”.

@ @ - 1 |‘ » Control Panel » System and Security ¢ Windows Firewall v G| | Search Control Panel » |

Help protect your PC with Windows Firewall

Control Panel Home
‘Windows Firewall can help prevent hackers or malicicus software from gaining access to your PC through the

Allow an app or feature Internet or a network.
through Windows Firewall
@ Change notification settings l @ Domain networks Connected @
@ Turn Windows Firewall on or X
Metworks at a workplace that are attached to a domain

off
@ Restore defaults

Windows Firewall state: On
Black all connections to apps that are not on the list

Incoming connections:
of allowed apps

Troubleshoot my network

Active domain networks: E frms.com
Motification state: Do net notify me when Windows Firewall blocks a
new app
l @ Private networks Not connected ®|
. @ Guest or public networks Not connected ®|

See also
Action Center

Metwork and Sharing Center

Click “Inbound Rules”.





File Action View Help

ewall with Ad
I

indows Fir i
o]
!‘l‘ Connection Security Rules
1+ %l Monitoring

Name

@saL1433

@Taamwewer Remote Control Application
@Taamwewer Remote Control Application
@Taamwewer Remote Control Service
OTEame\MEr Remote Control Service

. BranchCache Content Retrieval (HTTP-In)
. BranchCache Hosted Cache Server (HTT...
. BranchCache Peer Discovery (W5D-In)

. COM+ MNetwork Access (DCOM-In)

. COM+ Remote Administration (DCOM-In)
@ Core MNetworking - Destination Unreacha...
0 Core Networking - Destination Unreacha...
0 Core Networking - Dynamic Host Config...
0 Core Networking - Dynamic Host Config...
0 Core Networking - Internet Group Mana...
@ Core Metworking - IPHTTPS (TCP-In)

(@ Core Networking - IPv6 (IPv-In)

@ Core Metworking - Multicast Listener Do...
@ Core Metworking - Multicast Listener Qu...

0 Core Networking - Neighber Discovery A...

OCore Networking - Multicast Listener Rep...
OCore Networking - Multicast Listener Rep...

Inbound Rules

Group

BranchCa
BranchCa
BranchCa
COM+ N

COM-+ Re
Core Nety
Core Nety
Core Netv
Core Netv
Core Netv
Core Netv
Core Nety
Core Nety
Core Nety
Core Nety
Core Netv
Core Netv

[<] ] [3]

(<[ m

|

w

W3 NewRule..
Filter by Profile

'
'
'

Filter by State
Filter by Group
View

Refresh

Export List...

BiD

Help

- vy v -

Click “New Rule...”.

File Action View Help

= z7E = B

‘ ‘Windows Firewall with Advance

nbound Rules

Outbound Rules
' Connection Security Rules
1 %l Monitoring

Inbound Rules

Mame

@saL1433

@Teamviewer Remote Control Application
@Teamviewer Remote Control Application
@Teamviewer Rernote Control Service
@Teamviewer Rernote Control Service
.Bran(hCachE Content Retrieval (HTTP-In)
.Bran(hCachE Hosted Cache Server (HTT...
.BranchCache Peer Discovery (W5D-In)

. COM+ Network Access (DCOM-In)

. COM+ Remote Administration (DCOM-In)
@Core Metworking - Destination Unreacha...
@Core Metworking - Destination Unreacha...
@Core Metworking - Dynamic Host Config...
@Core MNetworking - Dynamic Host Config...
@Core Networking - Internet Group Mana...
@CDrE Networking - IPHTTPS (TCP-In)
@CDrE Networking - IPvb (IPvb-In)

BCnre Networking - Multicast Listener Do...
@Core Netwaorking - Multicast Listener Qu...

@Core Metworking - Multicast Listener Rep...
@Core Metworking - Multicast Listener Rep...
@Core Metworking - Meighbor Discovery A..

Group

BranchCa
BranchCa
BranchCa
COM+ Ne
COM+ Re
Core Metv
Core Metv
Core Metv
Core Metv
Core Metv
Core Metv
Core Metv
Core Netv
Core Metv
Core Metv
Core Metv
Core Metv

New Rule...

'
'
'

Filter by Profile
Filter by State
Filter by Group
View

Refresh

Export List...

BB

Help

v

(<] [ [>

<[

[>]

r v v ¥

Select “Port” and then click “Next”.





Rule Type
Select the type of firewall rule to create.

Steps:
Rule Type
Protocol and Ports
Action
Profile

What type of rule would you like to create 7

) Program
Rule that controls connections for a program

Name

@® Port
Rule that controls connections for a TCP or UDP port.

) Predefined:
| BranchCache - Content Retrieval (Uses HTTF)

Rule that contrals connections for a Windows experience.

) Custom
Custom rule.

vi. Select “TCP”, then select “Specific local ports”, type the SQL port number, and click

“Next”.

Protocol and Ports
Specify the protocols and ports to which this rule applies.

Steps:
@ Rule Type

@ Protocol and Ports
@ Action

@ Profile

L

Name

Does this rule apply to TCP or UDP?

® TCP
O upP

Does this rule apply to all local ports or specific local ports?

O All local ports

® Specific local ports: | 1433
Example: 80, 443, 5000-5010

<Back || MNed> |[ Cancel

vii. Select “Allow the connection”, and then click “Next”.





Action
Specify the action to be taken when a connection matches the conditions specified in the rule.
Steps:

Rule Type
Protocol and Ports

What action should be taken when a connection matches the specified conditions?

i ® Allow the connection
Action This includes connections that are protected with |Psec as well as those are not.
Profile

N () Allow the connection if it is secure
ame This includes only connections that have been authenticated by using IPsec. Connections
will be secured using the settings in |Psec properties and rules in the Connection Security
Rule node.

) Block the connection

viii. Choose when to apply the rule.

Profile
Specify the profiles for which this rule applies.

Steps:
Rule Type

Protocol and Ports

Action [+] Domain
Applies when a computer is connected to its corporate domain.

‘When does this rule apply?

Profile

Name ] Private
Ppplies when a computer is connected to a private network location, such as a home
or work place.
v Public
Applies when a computer is connected to a public network location.

iX. Specify the name and description of the rule and then click “Finish”.





Name

Specify the name and description of this rule.

Steps:
Rule Type
Protocol and Ports

Action
Profile Name:

[saL 1433

Name

Description (optional):
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Foxit Reader

Quick Guide
the web service and SQL first, and then enable the extended policy with the Foxit
Configuration Tool.

2.3. Check the additional settings and select a security watermark. For the instructions on
how to add a security watermark, please refer to “Security Watermark Management”.
2.4 If needed, click Save Defaults to make the additional settings the default.

e  (Click OK to encrypt the PDF files with the settings you specified.

Permission

[ |Restrick permissien ko this document

Enter the e-mail addresses of users in the Read and Change boxes [example:
'someone@example.com'). Separate names with a semicolon(;).

Assign users with Read
permission

Permissions for Read

=

— Assign users with

Users with Read permission can read this document, but cannot change,

print or copy content. Change permission

Permissions for Change

| E / Specify additional

— permissions and settings

Users with Change permission can read, edit, copy conkent from, and save
changes to this document, but cannot print content. /

More options...

| Cancel | OK
s

[ Restricted permission to this document

User list The following users have permission to this document:
\ Name Access Level | Add.. |
user1@isvtenant... Full Control

| Remove

Specify the additional

permissions to the PDF file

rAdditional permissions for Users.
["] This document expires on: 2016/08/03 v 18:54
\ ["] Print content
["] Allow users with read access to copy content
Specify the additional [] Allow users with read access to comment and fill form fields
settings to the PDF file Eedoc pnict,

rAgUTTIoTat SEteTgs:
\ [& User can request additional permissions from:

| mailto:user1 @isvtenant006.onmicrosoft.com

["] Require a connection to verify a user's permission

® Security Watermark:

|.WatermarkTemplate | select

| set Defaults... | | Save as Template |

| concel | (ORI
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Create Custom Templates

e  Goto Protect > RMS Settings > Custom Templates;

e  Click Create: You can click Edit or Delete to edit or delete an existing custom template.

e Specify the template outline, and click Next.

e Add users, check the permissions for users, and click Next.

e Specify when the content expires, and click Next.

e Select the security watermark and extended policies, and click Finish. For detailed
instructions, please refer to Security Watermark Management and Extended Policy.

e (Click OK, and the custom template will be added to the template list under Restricted
Access.

Security Watermark Management

e  Go to Protect > RMS Settings > Security Watermark;
e Do one of the following:

1. New Profile: Add a new watermark profile.

2. Add: Add a security watermark.

3. Edit: Edit an existing watermark.

4. Delete: Delete the selected watermark.

@ Manage Security Watermark

Select Profile Preview

Hew Profile

Foxit Configuration Tool (Used in Windows RMS Server)

Foxit Reader RMS protector provides a handy configuration tool for administrators to better
modify the protection settings on a RMS server. Administrators can directly enable/disable each
tool, edit the extended policies of official templates, dynamically revoke permissions, audit logs,

set valid network printers, and customize wrapper files.
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Foxit Reader

Quick Guide
To use the configuration tool to encrypt PDFs, please do the following:
e Logintoyour RMS server.
e Download the Foxit Configuration Tool from:
For X86:
http://cdn01.foxitsoftware.com/pub/foxit/rms/configtool/8.x/FoxitConfigurationTool 32.zip
For X64:

http://cdn01.foxitsoftware.com/pub/foxit/rms/configtool/8.x/FoxitConfigurationTool 64.zip

e Unzip and Run Foxit Configuration Tool, you can then use the different tools in the Foxit
Configuration Tool window.

»

Template Extended Palicy Revocation Extended Policy

£

Audit Log valid Network Printer Setting Editing Wrapper Content

Foxit Configuration Tool Window
Template Extended Policy

With the Foxit Configuration Tool, administrators can easily edit the extended policy of official
templates. Click Template Extended Policy tool and choose one template to edit. See also

Extended Policy.
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http://cdn01.foxitsoftware.com/pub/foxit/rms/configtool/8.x/FoxitConfigurationTool_32.zip
http://cdn01.foxitsoftware.com/pub/foxit/rms/configtool/8.x/FoxitConfigurationTool_64.zip

Foxit Configuration Tool Hi-

Edit

Termplate Narme Security Watermark Access Pages Access Times  Print Times Arcess IP
Expiration

test(guanfang)

watermark watermnark Ternplate

Tip: Click the Back button in the left corner to return to the Foxit Configuration Tool

window.

Dynamic Revocation

Revocation is a mechanism that revokes a PDF document that has already been issued. A
common use of revocation is to remove rights from an individual when he is no longer
authorized or to restrict access to a document when it becomes out of date or invalid.

Note: To revoke a PDF document/user in an on-premise environment, please refer to Web Service
Configuration to configure the web service and SQL first. Then choose the Revocation tool in the

Foxit Configuration Tool window and enable the tool by clicking the button
To revoke a PDF document, click Document Revocation. Select the PDF document you want to
revoke, click the Add button to add the document to the Revocation List. Or you can click Browse

to select a document from a local drive to add to the Revocation List. To remove the revocation,

please select the document in the Revocation List and click the Remove button.
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Foxit Configuration Tool |L|i-

Add the document: to the Revocation List |0. Content ID v

Content ID Termplate Narne Creator File: Marne Date Time -~ Add

{BEEFBAF2-2BB3-4... Expiration administrator@rno...  ADFStest.pdf 03/22{2016 13:16...

{8CD=CSD0-8A04-,..  Bxpiration administrator@mo...  ADFS@.pdf 03/22{2016 15:38... Browse

{S0BBFIES-F101-4... 1130-6 rs@mobile dev.fo..  323-33.pdf 03/23/2016 12:17... |

{4AD34884-0027-4... 1130-6 rs@mobile dev.fo...  323-44.pdf 03/23/2016 12:19.., hate:

{DOS9C1C1-6180-4.., 11306 rms@mobile.dev.fo... 32355 pdf 03/23/2016 12:20 You can cick Browss to
Rl b S select a document from

{110702BE-26CB-4... 1130-5 rms@mobile dev.fo...  323-88.pdf 03f23/2016 13:58.., local drive ta Revacation

{~B472029-D959-4... low print administrator@mo...  low print, podf 04/01/2016 16:25... List,

Wz e

Revocation List

Content ID Template Name Creatar File: MName Date Time Remove
2233 444 dd dd.pdf 09/08/2015 00:00...
1/1

To revoke a user, click User Revocation. Click Add button to add a user to the User Revocation List.

To remove the revocation, please select the user in the list and click Remove button.

G Foxit Configuration Tool EEIE]

User Revocation List

User Mame Date Timne
&testerDl@mnhi\e.dev‘fnxitsnftware‘m 02/25/2016 12:42:19

Add Remove

Extended Policy

Foxit Configuration Tool provides you with Extended Policy to add complete PDF protection and
control to your PDF documents. The policy allows documents owners to control the number of
access and the number of prints in an on-premise environment. Before you specify the two
permissions, please refer to Web Service Configuration to configure the web service and SQL first,

and then choose the Extended Policy tool in the Foxit Configuration Tool window and enable the

tool by clicking the button
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| Foxit Configuration Tool l;‘i-

Complete PDF protection and control of document usage. The policy will dlow docurment owners to control the
following items. To specify the ‘number of accesses' and 'nurnber of prints' items in an on-premise environment,
Please refer to web Service Configuration to configure the web service and SQL first, and then enable ‘Extended
Policy',

Auditing Logs
Foxit Reader enables you to track the usage of RMS protected files to record the actions on the
files during workflow, including who accessed the document, what document was accessed,

when it was accessed, how it was accessed and the success of that access, and more.

To audit logs, please refer to Web Service Configuration to configure the web service and SQL first,

and then choose the Audit Log tool in the Foxit Configuration Tool window and enable the tool by

clicking the button
G| Foxit Configuration Tool \L‘i-

o] [user v Expurt

User Action File Marme Date Time 1P Printer Name Copies Print Range -~
rms@mobile.d... Closed mobile. pdf 3/17/2016 10:14:0... 10.203.17.122
tms@mohbile.d... Opened oo pdf 3/17/2016 1:45:44 ... 10.203.17.122
rms@mobile.d... Closed oo pdf 3{17/2016 1:46:32 .., 10.203.17.122
rms@mobile.d... Opened oo pdf 3/17/2016 2:07:20 ... 10.203.17.122
rmns@mobile.d... Closed oo pdf 3/17/2016 2:07:56 ... 10.203.17.122
rms@mobile.d... Cpened oo pdf 3{17/2016 2:42:12 .., 10.203.17.122
rms@mobile.d... Changed oo pdf 3/17/2016 2:45:52 ... 10.203.17.122
rms@mohbile.d... Saved oo pdf 3/17/2016 2:4A:58 ... 10.203.17.122
rs@mobile.d... Closed o pdf 3{17/2016 2:46:58 .., 10.203.17.122 =
rms@mobile.d... Opened oo pdf 3/17/2016 2:47:02 ... 10.203.17.122
rmns@mobile.d... Closed oo pdf 3/17/2016 2:47:21 ... 10.203.17.122
re@mobile.d... Opened e pdf 3{17/2016 2:49:11 ... 10.203.17.122
rms@mobile.d... Changed oo pdf 3/17/2016 2;50:21 ... 10.203.17.122
rms@mohbile.d... Saved oo pdf 3/17/2016 2;50:26 ... 10.203.17.122
rz@mobile.d... Closed e pdf 3{17/2016 2:50:27 ... 10.203.17.122
rms@mobile.d... Opened o podf 3{17/2016 2;50041 ... 10.203.17.122
rmns@mobile.d... Closed oo ppdf 3/17/2016 2;50:45 ... 10.203.17.122
re@mobile.d... Opened o ppdf 3{17/2016 2:50:50 ... 10.203.17.122
rms@mobile.d... Closed oo podf 3{17/2016 250055 ... 10.203.17.122 »
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Choose one log and click on the Export button to export to Foxit Reader’s registry or Foxit
PhantomPDF'’s to generate a .reg file for the administrator’s configuration. The administrator can
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distribute the .reg file to client-end computers.

Edit Wrapper Content

If you open a PDF which is encrypted by Foxit with other PDF viewers, a wrapper (which is a PDF
page) appears with a prompt that you need to download Foxit Reader/PhantomPDF to open the
encrypted PDF. With Foxit Configuration Tool, you can customize the wrapper by selecting a
desired PDF file.

To apply a custom wrapper, please refer to Web Service Configuration to configure the web
service and SQL first. Then choose the Edit Wrapper Content tool in the Foxit Configuration Tool

window, enable the tool by clicking the button , and select a desired PDF file.

G} Foxit Configuration Tool == -

If you open a POF which is encrypted by Foyit with other PDF programs, a wrapper (which is actually a PDF
page) will prompt you to download Foxit PhantomPDF/Reader to apen the POF, If you want to edit the
wrapper content, please save the updated content as a POF file, and dlick 'Select’ to choose this POF file,

Wrapper: | 123455 pf | ‘ Select

RMS Decryption

You can decrypt the RMS protected PDF file if you are authorized.

e  Open the encrypted PDF file with Foxit Reader;
e Loginto the RMS account;
e  Choose Protect > Unrestricted Access, and confirm the operation.

Change RMS Account

After login to the RMS server, you can go to Protect > RMS Settings > Change Account to switch

RMS accounts.
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Chapter 5 Work with ConnectedPDF

ConnectedPDF extends the ISO PDF standard to allow each PDF to carry an identity assigned by a
cloud service, and allows document tracking and sharing no matter where a document goes or

how many distributions and modifications are done to it.
Foxit Reader’s ConnectedPDF features include:
° Sign in to Foxit Account

° Convert PDF File to cPDF

° Register New Version

° View Document Information of cPDF
° Work with a Protected cPDF
° Participate in Connected Review

For more information about ConnectedPDF, please visit
http://cdn01.foxitsoftware.com/pub/foxit/manual/cPDF/en us/FoxitConnectedPDF Manual.pdf.

AboutFoxit_converted_protected.pdf (SECURED) - Foxit Reader
File Edit Vview Tools Comments Protect [€ONNEEE| Share Help

O e 2 18% v & 172 | L «| £ TI|v/|Q-Find -

Register New Version

Convert ko cPD En Register New\ B VeV yjiew Permissions ¢ & Connected Rev [B% Document Hon &8 Tutorials
Start Datasheet_Reader... Save Offline Copy g g
Connected Review I
Document Homepage
Tutorials

Foxit is a leading software provider of fast, affordable, and secure PDF solutions. Businesses
and consumers increase productivity by using Foxit's cost effective solutions to securely work
with PDF documents and forms. Software developers reduce costs and improve time to
market with Foxit's Software Development Kits (SDKs) to incorporate robust PDF technology
into their application workflows. This technology shares the same underlying technology that
powers Google's open-source PDFium project. Winner of numerous awards, Foxit boasts
over 427 million users and has sold to over 100,000 customers located in over 200 countries.
Since Foxit products are |1SO 32000-1/PDF 1.7 standard compliant, they are compatible with

other PDF products like those from Adobe®. =
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Contact Us

Feel free to contact us should you need any information or have any problems with our products.
We are always here, ready to serve you better.

o Office Address:
Foxit Software Incorporated
42840 Christy Street. Suite 201
Fremont CA 94538
USA

e Sales:
1-866-680-3668 (24/7)

e Support:
1-866-MYFOXIT or 1-866-693-6948 (24/7)

e Fax:
1-510-405-9288

o Website:
www.foxitsoftware.com

e E-mail:

Sales and Information - sales@foxitsoftware.com

Technical Support - Input a trouble ticket online

Marketing Service - marketing@foxitsoftware.com
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